LaTeX forum ⇒ LyXlyx2lyx fails to convert

Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.
nephologue
Posts: 4
Joined: Thu Aug 11, 2022 7:39 pm

lyx2lyx fails to convert

Postby nephologue » Thu Aug 11, 2022 7:50 pm

Hi. Got an old file written with LyX 1.6 in 2009 that I want to resurrect but am getting the error message that

*.lyx is from an older version of LyX and the lyx2lyx script failed to convert it.

Using LyX 2.3.6.2 on MacOS Monterey.

Any suggested work arounds? Not finding solutions online, though it must be a common problem.

Thanks

Tim

Recommended reading 2021:

LaTeXguide.org • LaTeX-Cookbook.net
LaTeX Beginner's Guide LaTeX Cookbook
User avatar
MjK
Posts: 48
Joined: Fri Jan 28, 2022 6:09 pm

lyx2lyx fails to convert

Postby MjK » Sat Aug 13, 2022 1:27 pm

You can find previous versions of LyX on the LyX download page. However you may also need old versions of Qt and other software. Usually using a virtual machine (e.g. with an old Linux) is a good idea for such problems.

Another suggestion would be to subscribe to the LyX users mailing list and ask there for help.

Disclaimer: I'm neither a Mac user nor a LyX user. Therefore I cannot and will not provide any further support.
My main topics are KOMA-Script and other questions related to my packages. If I reply to any other topic or if you've not yet added a minimal working example, please do not expect any further response. And please don't forget to tag examples as code.

nephologue
Posts: 4
Joined: Thu Aug 11, 2022 7:39 pm

lyx2lyx fails to convert

Postby nephologue » Mon Aug 15, 2022 11:12 pm

Yes, tried old versions of LyX but they won't install. Doubt I have the skills to go down the rabbit hole of trying to make it work. Hopefully there's another solution.

User avatar
MjK
Posts: 48
Joined: Fri Jan 28, 2022 6:09 pm

lyx2lyx fails to convert

Postby MjK » Tue Aug 16, 2022 9:42 am

As I already wrote: Installation of an old LyX usually also needs other old software. So using a virtual machine with an old Linux would be recommended. For example ready to use Debian VM images are available for several Debian releases. I would first try a Debian 8 Jessie image. But maybe you even have to search for a Debian 7 Wheezy image depending on the LyX version you would try to install.

And if you'll fail with this, I also gave you a link, to increase your chances in getting help for such a very special problem.
My main topics are KOMA-Script and other questions related to my packages. If I reply to any other topic or if you've not yet added a minimal working example, please do not expect any further response. And please don't forget to tag examples as code.

nephologue
Posts: 4
Joined: Thu Aug 11, 2022 7:39 pm

lyx2lyx fails to convert

Postby nephologue » Thu Aug 18, 2022 5:09 am

Sorry, I don't have access to an old linux machine. Not at all. I work as a professor for a university that limits what I can use and linux ain't it. If you have a suggestion for a link to another solution it would be very much appreciated as past article drafts I've written are currently inaccessible to me. Much appreciation for your help here.

User avatar
MjK
Posts: 48
Joined: Fri Jan 28, 2022 6:09 pm

lyx2lyx fails to convert

Postby MjK » Thu Aug 18, 2022 9:02 am

You don't need a real computer with Linux. As I already told: You can use a virtual machine, e.g., with VirtualBox, VMWare, Parallels, UTM … Ask you administrator.

And once again: If all this is not possible, subscribe to the LyX user mailing list (link was added in previous reply) and ask there. Maybe the LyX developers there can help you converting your old LyX files. However they also would need some more cooperation. For example, you should provide more information about the problematic LyX file and the exact error message. Free software development usually depends on user reports.

This is all I can say. And I would not expect, that anyone here can say much more currently. So this is my last reply to this thread.
My main topics are KOMA-Script and other questions related to my packages. If I reply to any other topic or if you've not yet added a minimal working example, please do not expect any further response. And please don't forget to tag examples as code.

nephologue
Posts: 4
Joined: Thu Aug 11, 2022 7:39 pm

lyx2lyx fails to convert

Postby nephologue » Sun Aug 21, 2022 7:38 pm

Through the LyX forum, the result that worked was the following


/System/Volumes/Data/Applications/LyX.app/Contents/Resources/lyx2lyx/lyx2lyx -v oldfile.lyx > newfile.lyx

Incidentally, the only Linux allowed on my university campus is at the Center for High Performance Computing, which does not have any old linux machines VPN or otherwise.

User avatar
MjK
Posts: 48
Joined: Fri Jan 28, 2022 6:09 pm

lyx2lyx fails to convert

Postby MjK » Sun Aug 21, 2022 7:58 pm

nephologue wrote:Through the LyX forum, the result that worked was the following

/System/Volumes/Data/Applications/LyX.app/Contents/Resources/lyx2lyx/lyx2lyx -v oldfile.lyx > newfile.lyx

So your initial statement:
nephologue wrote:the lyx2lyx script failed to convert it.

was wrong and almost all of my replies where wasted time. :(

I really should not reply to LyX questions any more. :roll:

Never the less: Thank you for showing the solution.


Return to “LyX”

Who is online

Users browsing this forum: No registered users and 2 guests